Vxdiag Subaru Software Compatible: SSM3 or SSM4?

Here, we’ll talk about SSM3 and SSM4 working for Allscanner Vxdiag Subaru

 

What is SSM?

SSM, the short form of Subaru Select Monitor, is an OBD based tool that allows configuration and customisation of the Engine Control Unit (ECU) and Transmission Control Unit (TCU), which is great for diagnostic and tuning purposes. It can be used for Subaru vehicles from MY1999 onwards, including the Legacy, Liberty, Outback, Baja, Impreza, Forester and Tribeca.

 

What is SSM3?

SSM3 software is designed to work for model years 1998-2016 using Hitachi HDS3000 or the newer Denso DST-i. It doesn’t work at all with standard OBD2 devices.

 

What is SSM4?

SSM4 works with model years 2016+ and it’s designed to work with the Denso only.

 

 

Subaru SSM3 on Vxdiag?

Confirmed!

The  third-party tool called VXDIAG which claims to work with SSM3 and they provide instructions on cracking the software. Most are interested in it for personal use. PP think it good when use VXDIAG SSM3

 

Subaru SSM4 on Vxdiag?

You need luck!

 

The official has not tested SSM4 software with VXDIAG Subaru. So, Allscanner holds no responsibility of what you will do with SSM4 on VXDIAG.

 

But some users tested it successfully.

Vxdiag can support Subaru SSM4, but it need license for it, so you need to use Subaru SSM3 with our device.
Subaru SSM installation guide:
1.Click Launcher.exe, first to install SSM3, then to install SSM4
2.Save Subaru.exe to folder of C or D, Install it on win 7 or up, right click to run
3.Restart laptop, click SSM3 to test car after connecting device to laptop and car.

 

 

Questions and answers here might help you out.

Q1: Can i use SSM4 (Subaru Select Monitor IV) software with VXDIAG Multi Tool for Subaru?

A1: No. VXDIAG Subaru is compatible with SSM3 software only.

 

Q2:  I try to install VXDIAG Subaru SSM3 software, it gave me an error “Com. with All systems Failed”. Interface was connected and the device indicator turned red.  The I saw there is a SSM4 software folder, then installed SSM4, it told me to change computer date otherwise the SSM4 license will be invalid soon.

A2: To install VXDIAG Subaru SSM III software, you need to install the patch as well.

Don’t not run SSM4 software. It is not compatible with SSM4.  DO always run SSM-3 software.

 

Q3: Do you have newer version SSM4 that can work with the VXDIAG vcx plus?

“Subaru Select Monitor 4

You are trying to install an old version of the SSM4 software.

The activation period for this version expires.

Please install the latest version software”

Vxdiag Subaru Ssm4 Expire Error

But they way, when i diagnose full system with Subaru SSM3 software, it gave me another error:

“CF application version update failed. ErrCode=2”

A 3: 1)Our VXDIAG multi tool is compatible with SSM3 software only. Don’t install SSM4 software.

2)If you have SSM3 error code 2, press OK to continue.